五特知识分享网

5均线上方第一个跳空缺口公式

求个通达信向上跳空缺口的预警选股公式,谢谢!

XG:L>REF(H,1) AND C/REF(C,1)>1.05;

(已测试)

通达信选股公式 同时存在 向下跳空缺口 向上跳空缺口 出现缺口时 股价大致相同或相近差距<5%

选股公式:
{缺口}
YZZT:=C=O AND C>REF(C,1) AND (C-REF(C,1))/REF(C,1)>0.095;
YZDT:=C=O AND C<REF(C,1) AND (REF(C,1)-C)/REF(C,1)>0.095;
SSQK:=O>REF(H,1) AND C>O AND NOT(YZZT);
XDQK:=O<REF(L,1) AND C<O AND NOT(YZDT);
TSCZ:= EXIST(SSQK,20) AND EXIST(XDQK,20);
SSQKJG:= REF(H,BARSLAST(SSQK));
XDQKJG:= REF(H,BARSLAST(XDQK));
JGJJ:= ABS(SSQKJG-XDQKJG)/SSQKJG<=0.01;
QKXG: TSCZ AND JGJJ;
主图公式:
{缺口}
YZZT:=C=O AND C>REF(C,1) AND (C-REF(C,1))/REF(C,1)>0.095;
YZDT:=C=O AND C<REF(C,1) AND (REF(C,1)-C)/REF(C,1)>0.095;
SSQK:O>REF(H,1) AND C>O AND NOT(YZZT),NODRAW;
XDQK:O<REF(L,1) AND C<O AND NOT(YZDT),NODRAW;
DRAWTEXT(SSQK,O,'SS'),COLORYELLOW;
DRAWTEXT(XDQK,O,'XD'),COLORYELLOW;
TSCZ:= EXIST(SSQK,20) AND EXIST(XDQK,20);
SSQKJG:= REF(H,BARSLAST(SSQK));
XDQKJG:= REF(H,BARSLAST(XDQK));
JGJJ:= ABS(SSQKJG-XDQKJG)/SSQKJG<=0.01;
QKXG:= TSCZ AND JGJJ;

怎样编写回踩第一个向上跳空缺口选股公式(通达信)?

X:=L>REF(H,1);
T:=BARSLAST(X);
Y:=REF(L,T);
Z:=REF(REF(H,1),T);
T>0 AND CROSS(Y,L) AND L>Z AND MIN(C,O)>Y;

帮忙下通达信选股公式,N天内有过一次以上跳空缺口,

XG:COUNT(L>REF(H,1),N)=1;{N---天数,自己定义}

如何写一个 通达信MA移动平均价公式

均价:=(HIGH+OPEN+LOW+CLOSE)/4;
VMA1:MA(均价,5);
VMA2:MA(均价,10);
VMA3:MA(均价,20);
VMA4:MA(均价,30);
VMA5:MA(均价,60);

通达信公式在下面公式里面加上ma均线

VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'买入'),COLORRED;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖1>0,HIGH*1.02,'卖出'),COLORGREEN;
{股灵吧决策}
VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
A:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
A0:=(AH-AL)/40;
B1:=L-A0;
STICKLINE((A+0)/34=FLOOR((A+0)/34),B1,B1-1.5*A0,3,0),COLORF00FF0;
DRAWTEXT((A+0)/34=FLOOR((A+0)/34),B1-1*A0,'时间窗'),COLORWHITE;
ma:ma(c,5) ;