五特知识分享网

通达信不划线公式,通达信趋势通道画线公式

内容导航:
  • 通达信指标公式不要数值,只要画线
  • 通达信不是指标画线公式,不能指定画线类型!
  • 跪求高人帮我改一个通达信的公式要可以选股的不要画线的
  • 同花顺里,怎么表示不画线,通达信是DRAWNULL
  • 请教高手通达信软件如何添加自由画线?谢谢
  • 通达信指标中如何自动画线
  • Q1:通达信指标公式不要数值,只要画线

    副图指标显示数值的小数位数是可以按需要自行设置的,方法如下:

    鼠标右击指标公式,选择“修改当前指标公式”(或直接组合键Alt+S),打开公式编辑器后打开“显示小数”下拉菜单,选项中有缺省位数(两位)、和固定0位、固定1——4位,根据自己需要选择其一即可。

    Q2:通达信不是指标画线公式,不能指定画线类型!

    1,由于条件选股公式是不要求图形显示的,所以不能指定画线类型,如POINTDOT,LINETHICK4,COLORYELLOW 这类描述线类型,线粗,线色的函数当然就不能要了,
    2,更不用画柱线,如STICKLINE(((C >= 工作线) AND (C >= O)),H,L,0,1),COLORRED;之类
    {想呀,按条件来选股的,怎么可能画出柱子来}
    3,条件选股公式就是告诉电脑按什么条件来选股,所以只能有一个最终输出的语句,也就是只能有一句冒号后面不用等号,如果多于1个输出了,那电脑怎么知道你到底要干什么
    4,条件选股不要求电脑显示什么指定的文字吧,如:DRAWICON(A26,(LOW / 1.015),1),LINETHICK2,COLORMAGENTA;
    DRAWTEXT(CROSS(A4,A3),L*0.9,'线上阴线买|买错也要买!线下阳线卖|卖错也要卖!'),LINETHICK4,COLORYELLOW; 你选股时还要求电脑显示这些图形和文字出来吗?

    Q3:跪求高人帮我改一个通达信的公式要可以选股的不要画线的

    MA3:=MA(C,3);
    MA5:=MA(C,5);
    ZX:=(MA3+MA5)/2;
    MA30:=MA(C,30);
    QSXS:=MA5>=MA30 AND MA30>REF(MA30,1);
    GD:=ZX>=REF(ZX,1) AND REF(ZX,1)<REF(ZX,2);
    YB:=C>REF((O-C)/2+C,2);
    买:=CROSS(C,ZX) AND (GD OR YB) AND QSXS;
    优:买 AND MA5>REF(MA5,1);
    ------------------------------
    试试,看现在怎么样,对比一下与你原来的指标在哪些方面有所不同,搞清楚了不同之处,以后自己就可以处理类似的问题,不用"跪求"了,-------你说呢

    Q4:同花顺里,怎么表示不画线,通达信是DRAWNULL

    额。。想想。。

    Q5:请教高手通达信软件如何添加自由画线?谢谢

    DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIF,9);
    MACD:=(DIF-DEA)*2;
    有一种小软件,名字是“红柱教鞭”,可以用这个在K线图上任意画。

    Q6:通达信指标中如何自动画线

    自动画线太多了,给你一个我看好的,源码下面网址里有图片演示.
    该指标能够做到对前期高点和最近高点的连线、前期低点和最近低点的连线、阻力位和支撑位的平行直线的连线,可以说简单易懂,一目了然。这类指标要用到未来函数,通常不做为买卖信号的参考。但该指标在一定周期内根据K线的走势所画的线已经成立,因此股价突破前高或颈线的点位还是比较可靠的,大家不妨在实战中来验证。所以,除了主图以外,还编制了选股指标。
    指标中的实线为高、低点连线,虚线为阻力位和支撑位。
    该指标可以复制粘贴到任何主图里。
    MA7:MA(C,7),COLORWHITE;
    MA14:MA(C,14),COLORYELLOW;
    MA25:MA(C,25),COLORFF00FF;
    MA120:MA(C,120),COLORFFCC66;
    QA:=REF(H,10)=HHV(H,2*10+1);
    QB:=BACKSET(QA,10+1);
    QC:=FILTER(QB,10) AND H=HHV(H,10+1);
    QD:=BARSLAST(QC);
    QE:=IF(QC,CURRBARSCOUNT,0);
    QF:=IF(QD,REF(QE,QD),QE);
    QG:=CONST(QF);
    QH:=REF(QF,QD+1);
    QW:=CONST(QH);
    DRAWLINE(CURRBARSCOUNT=QW,H,CURRBARSCOUNT=QG,H,1),COLORGREEN;
    DRAWLINE(CURRBARSCOUNT=QW,H,ISLASTBAR,REF(H,QW-1),1),COLOR0099FF,POINTDOT;
    DRAWLINE(CURRBARSCOUNT=QG,H,ISLASTBAR,REF(H,QG-1),1),COLOR0099FF,POINTDOT;
    QM:=INTPART(3*8/5);
    QR:=REF(H,QM)=HHV(H,2*QM+1);
    QT:=FILTER(QR,QM);
    QY:=BACKSET(QT,QM+1);
    QU:=FILTER(QY,QM);
    QI:=BACKSET(ISLASTBAR,BARSLAST(QU)+1);
    QP:=QI>REF(QI,1);
    DRAWLINE(QU,H,QP,H,1),COLORRED;
    QA1:=REF(L,8)=LLV(L,2*8+1);
    QB1:=BACKSET(QA1,8+1);
    QC1:=FILTER(QB1,8) AND L=LLV(L,8+1);
    QD1:=BARSLAST(QC1);
    QE1:=IF(QC1,CURRBARSCOUNT,0);
    QF1:=IF(QD1,REF(L,QD1),L);
    QG1:=IF(QD1,REF(QE1,QD1),QE1);
    QH1:=CONST(QG1);
    QW1:=REF(QF1,QD1+1);
    QM1:=REF(QG1,QD1+1);
    QR1:=CONST(QM1);
    DRAWLINE(CURRBARSCOUNT=QR1,L,CURRBARSCOUNT=QH1,L,1),COLORBLUE;
    DRAWLINE(CURRBARSCOUNT=QH1,L,ISLASTBAR,REF(L,QH1-1),1),COLORWHITE,POINTDOT;
    DRAWLINE(CURRBARSCOUNT=QR1,L,ISLASTBAR,REF(L,QR1-1),1),COLORWHITE,POINTDOT;
    QT1:=REF(L,QM)=LLV(L,2*QM+1);
    QY1:=FILTER(QT1,QM);
    QU1:=BACKSET(QY1,QM+1);
    QI1:=FILTER(QU1,QM);
    QP1:=BACKSET(ISLASTBAR,BARSLAST(QI1)+1);
    QJ1:=QP1>REF(QP1,1);
    DRAWLINE(QI1,L,QJ1,L,1),COLORRED;
    SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
    SR2:=FILTER(SR1,10);
    SR3:=BACKSET(SR2,10+1);
    HD:=FILTER(SR3,10);
    前高:=REF(H,BARSLAST(HD));
    DRAWICON(CROSS(C,前高),L-0.20,3);{突破前高的信号}

    • 评论列表

    发表评论: